EventBus是不是不支持Android7.1 ?
澳门银河官网
澳门银河官网
当前位置 : 澳门银河官网 > 澳门银河官网开户

EventBus是不是不支持Android7.1 ?

这样的话只能用广播了?或者RxBus?

不论支不支持, 转投RxBus吧, TAG真是太好用了...

7.0还挺正常的,你这边是实际测试过有问题吗?另外RxJava还是可以的,不过内容丰富些,转过去好处很多,坏处就是很多东西你都想用RxJava替换,时间成本可能会增加。

实测7.0还是支持的,不知道你的不支持是出现什么问题?

eventbus原理是反射+观察者模式, 跟android版本没关系, 应该是你在activity里面写回调坑位的时候写的有问题吧。

我去了GitHub上了看了,issue中并未有关于不支持7.0的内容,你还是仔细检查下你的代码吧

支持。实测。
不过我觉得是你没有注册是原因。

广告位

澳门银河官网